아듀이노와 블루트스모듈 HC-06이 연결이 되지 않습니다.

메카 2016-10-18 (화) 17:34 3년전 7556  


사진이 첨부되지 않아서 사진은 링크로 돌립니다.


http://blog.naver.com/jms986/220265338929


사이트에서 구매한 모바일 로봇 종결세트의 구성품으로 제작중입니다.


모바일 로봇을 구동시키기 위해서 전선배선을 끝낸 뒤 핸드폰으로 검색해서 페어링을 하고


연결을 하니 분명 연결은 됫습니다. 하지만!, 핸드폰의 Byte 전송으로 알파벳을 입력을 해도 아무런 반응을 보이지 않았구요.


코딩과 배선을 아무리 천천히 뜯어봐도 문제가 보이지 않아서


부품들(DC모터 코딩 등등)을 하나하나 다 테스트 해보았는데


블루투스 모듈을 실험해 볼겸 메카솔류션 블로그의 hc-06을 그대로 테스트 해보았는데


구동이 되지 않았습니다.


그리고,


#include <SoftwareSerial.h>
// SoftwareSerial(RX, TX) 형식으로 블루투스 모듈과 교차하여 연결된다.
SoftwareSerial BTSerial(2, 3);
void setup()
{
Serial.begin(9600);
BTSerial.begin(9600); // 블루투스 모듈 통신 속도의 디폴트값
}
void loop()
{
if (BTSerial.available()) // 블루투스 모듈에서 수신된 데이터를 컴퓨터로
Serial.write(BTSerial.read());

if (Serial.available()) // 컴퓨터에서 수신된 데이터를 블루투스 모듈로
BTSerial.write(Serial.read());
}


위의 코드와 같은 내용을 업로드한 후

시리얼 모니터 창에 AT라고 입력 한 뒤 블르투스모듈 초기화를 시킬 수 있다는 내용을 알게되어서


업로드를 해보고 시리얼모니터창에 AT라고 입력을 해도 예상했던 OK가 출력이 되는것이 아닌,

아무런 반응을 보이지 않았습니다.


이 경우는 제가가진 블루투스 모듈이 불량인 것인가요??


답압하네요 ㅜㅜ






==================================



안녕하세요 메카솔루션입니다.

먼저 제품이 작동하지 않는 점에 대해서 죄송하단 말씀 드리겠습니다.

지금 보이는 증상으로는 블루투스 - 휴대폰 사이의 연결에 무언가 문제가 있는 것 같습니다.

우노를 제외하고 순수하게 블루투스 테스트를 하는 방법을 알려드리겠습니다.

먼저 우노에서 5V - VCC, GND - GND를 연결하여 블루투스에 전원을 공급해줍니다.
이때 블루투스의 빨간 LED가 깜박이면 정상입니다.

블루투스의 RX - TX를 선으로 연결해줍니다. 이때 RX나 TX에 연결된 선이 아무것도 없어야합니다.

휴대폰으로 블루투스 connect를 합니다. 이때 빨간 LED가 계속 점등되어 있습니다.

그 후 Byte Stream mode에서 아무 문자를 전송합니다.

이때 입력한 문자가 그대로 돌아오면 정상입니다.

만약 이렇게 해도 안된다면 제품 불량이 의심됩니다.

070-5033-5499로 연락주시면 조속히 처리 해드리도록 하겠습니다.

그럼 즐거운 하루 되시기 바랍니다.
메카리워즈 Image Map


모바일 버전으로 보기